DIY DTG - Build your own Digital T-Shirt Printer

 
User avatar
sonyoasis
Contributor
Posts: 25
Joined: Sat Aug 20, 2016 12:14 pm

Re: help me step motor tics

Thu Apr 20, 2017 6:34 am

Hard to tell by the video but it looks to me to be a problem with your platen system. If you disconnect the belt from the motor does your platen move back and forth smoothly?  
 
User avatar
Andy
Site Admin
Posts: 1325
Joined: Mon Jul 25, 2016 5:59 pm

Re: help me step motor tics

Thu Apr 20, 2017 7:27 am

My guess is that is a version that has the slow down in the front to keep the platen from slamming. In the settings change the speed of the slow down until you get what you prefer.
 
RedOne
Posts: 22
Joined: Sun Nov 06, 2016 8:17 pm

Re: help me step motor tics

Thu Apr 20, 2017 11:03 am

Even not use slowdown, sometimes its happen.
And I see, stepper rude when encoder sensor red light is on, but when printer is idle and light was off, stepper move normal. Any ideas?
 
User avatar
sonyoasis
Contributor
Posts: 25
Joined: Sat Aug 20, 2016 12:14 pm

Re: help me step motor tics

Thu Apr 20, 2017 2:55 pm

Andy is right if the stepper is running slow you can get that vibration you see in your video. Does it happen at the same point every time? What board are you using to control the printer ? 
 
RedOne
Posts: 22
Joined: Sun Nov 06, 2016 8:17 pm

Re: help me step motor tics

Thu Apr 20, 2017 5:21 pm

sonyoasis wrote:
Andy is right if the stepper is running slow you can get that vibration you see in your video. Does it happen at the same point every time? What board are you using to control the printer ? 

Yes, its happen rude when red led encoder sensor light is on, and smooth normal when red led encoder sensor light is off.
Iam use Arduino Nano, Nema 17, TB6600, Power Supply 24v 3A with stepdown 5v for arduino.
 
User avatar
sonyoasis
Contributor
Posts: 25
Joined: Sat Aug 20, 2016 12:14 pm

Re: help me step motor tics

Thu Apr 20, 2017 11:30 pm

Andy, Is his power supply suitable at 3 amp ? 
 
User avatar
Andy
Site Admin
Posts: 1325
Joined: Mon Jul 25, 2016 5:59 pm

Re: help me step motor tics

Fri Apr 21, 2017 8:06 am

sonyoasis wrote:
Andy, Is his power supply suitable at 3 amp ? 

I think it is a code thing since it works fine other times.
It seems to be happening around the front where the slow down is so it's either that code or if the encoder wheel is moving at the same time that is slowing the arduino down causing longer pauses in between steps.

Who is online

Users browsing this forum: No registered users and 1 guest